Затмение на win64

Кто-нибудь успешно использует последнюю 64-битную версию Eclipse от Ganymede в Windows XP или Vista, 64-битная?

В настоящее время я запускаю обычный дистрибутив Eclipse 3.4 на 32-битном JDK и запускаю и компилирую свои приложения с 64-битным JDK. Наш предыдущий опыт показал, что 64-битный дистрибутив Eclipse нестабилен для нас, поэтому мне любопытно, успешно ли кто-нибудь использует его.

Мы используем JDK 1.6.0_05.

8.08.2008 18:17:50
2 ОТВЕТА
РЕШЕНИЕ

Я использую Eclipse с 64-битной виртуальной машиной. Однако я должен использовать Java 1.5, потому что в Java 1.6, даже 1.6.0_10ea, Eclipse аварийно завершал работу при изменении .classpath-файла. В Linux у меня были те же проблемы, и я мог заставить работать только 64-битный Eclipse с 64-битной Java 1.5.

Проблема, похоже, связана с компиляцией точно в срок, поскольку с помощью vmparam -Xint eclipse работает - но это не решение, потому что тогда это происходит медленно.

Редактировать:

С 1.6.0_11 похоже работает.

1.6_10 final может работать так же, как упомянуто в комментарии, но я не проверял это.

7
20.01.2009 10:38:04
JDK 1.5 или 1.6.0_10 (сейчас не в бета-версии), кажется, лучший ответ
Joshua McKinnon 9.01.2009 00:44:09

Я успешно использовал его на Vista x64 для легкой работы на Java. Ничего слишком сложного и лишних плагинов, но базовое Java-кодирование работало без проблем. Я использую сборку 3.4M7, но похоже, что стабильная сборка 3.4 теперь поддерживает Vista x64.

1
8.08.2008 20:28:49