Ссылка 3.5 сборка из 2.0 приложения?

У меня есть сборка, которая предназначена для .NET 3.5.

У меня есть приложение, предназначенное для .NET 2.0, и мне интересно, возникнут ли у меня какие-либо проблемы со ссылкой на сборку 3.5 из приложения 2.0.

Я понимаю, что IL, предположительно, тот же, поэтому я предполагаю, что он будет работать, но хотел бы услышать некоторые впечатления от других, кто попробовал это.

В среде выполнения будут установлены версии 2.0 и 3.5.

15.12.2008 19:23:18
У меня точно такая же проблема. Несмотря на то, что приведенные ответы верны, я хотел бы узнать, как быстро определить ссылочные сборки, для которых требуется .Net версии 3.5, чтобы я мог, если возможно, вернуть их к версии 2.0.
Anthony 22.06.2010 15:26:32
2 ОТВЕТА
РЕШЕНИЕ

Нет проблем. Существует только одна версия времени выполнения приложения. .NET Framework v2.0.

8
15.12.2008 19:27:00

Тем не менее, при развертывании приложения .net2.0 вашему пользователю будет предложено установить .net3.5 (так как имеется ссылка на сборку .net 3.5).

4
22.02.2009 17:55:17