Установщик создания приложений WPF

Я создаю приложение WPF с использованием VS 2005. Я загружаю дополнение для создания приложения WPF. Теперь для развертывания приложения мне нужен установщик для автоматической загрузки компонентов WPF. Обратите внимание, что я не могу установить 3.5 framework на клиентский компьютер. Есть некоторые правила и вещи, которые мешают этому случиться.

3 wpf
11.12.2008 15:39:03
2 ОТВЕТА
РЕШЕНИЕ
3
14.12.2008 10:15:11

Для запуска приложения WPF необходим установленный .net 3.0 (он всегда предустановлен в Vista).

Существуют некоторые приемы для копирования некоторых библиотек dll 3.0 или 3.5 в установки .net 2.0, но это не поддерживается - это означает, что это может работать, но также может сломать другие приложения и перестать работать каждый раз, когда что-то обновляется в системе - так что, пожалуйста, не делай этого.

Хорошей новостью является то, что .net 3.5sp1 (плюс некоторые исправления ошибок) скоро появятся в обновлениях Windows - поэтому эта проблема может быть временной.

Если вы решили использовать 3.0, а не 3.5, вам нужно быть осторожным, чтобы не использовать что-то новое с 3.5 и протестировать 3.0 перед выпуском.

Кстати, поддержка WPF в VS2005 действительно плохая и никогда не была официально выпущена, вы можете рассмотреть возможность обновления до VS2008, даже с бесплатной экспресс-версией VS2008 инструменты разработки WPF намного лучше, чем VS2005.

0
14.12.2008 10:09:04
Привет, спасибо за ответ. Я постараюсь сделать 3,0. Да, VS 2008 поддержка WPF очень плохая. Я не могу обновиться до 3.5 по причинам компании.
azamsharp 15.12.2008 15:02:27