Неудачная цель propel-gen «convert-conf»

Я пытаюсь сгенерировать свои модели из файла schema.xml в OSX 10.5 с последними версиями PHP & Propel 1.3 & Phing. Все классы моделей фактически создаются, а потом просто умирают, прямо на последнем шаге. Я уже пробовала

chmod -R 777 ./application/config

но это не помогло Я также попробовал оба

propel-gen ./ реверс

а также

Propel-Gen. / Creole

Оба выдали одну и ту же ошибку. Эта ошибка:

propel > convert-conf:
[echo] Output file: models-conf.php
[echo] XMLFile: /application/config/runtime-conf.xml
Execution of target "convert-conf" failed for the following reason: pear/data/propel_generator/build-propel.xml:514:20: No valid xmlConfFile specified.
[phingcall] /pear/data/propel_generator/build-propel.xml:514:20: No valid xmlConfFile specified.

Execution of target "main" failed for the following reason: 
pear/data/propel_generator/build-propel.xml:94:18: Execution of the target buildfile failed. Aborting.
[phing] pear/data/propel_generator/build-propel.xml:94:18: Execution of the target buildfile failed. Aborting.

BUILD FINISHED

Вот мой файл build.properties:

propel.project = models
propel.database = mysql
propel.database.encoding = utf8
propel.database.url = mysql:host=localhost;dbname={$myDBName}
propel.database.user = {$myDBuser}
propel.database.password = {$myDBpass}
propel.output.dir  = /application
propel.php.dir     = ${propel.output.dir}/
propel.sql.dir     = ${propel.output.dir}/models/sql
propel.schema.dir  = ${propel.output.dir}/config
propel.conf.dir    = ${propel.output.dir}/config
propel.phpconf.dir = ${propel.output.dir}/config
propel.addGenericAccessors = true

Любые идеи?

11.12.2008 08:21:18
2 ОТВЕТА
РЕШЕНИЕ

Я не знаю, как это произошло, но в моем файле runtime-conf.xml была плохая строка:

<datasource id="models"> <!-- this ID must match <database name=""> in schema.xml -->

Видишь, как говорится, что эти вещи должны совпадать? Мой не сделал. Должно быть, я нажал клавишу, когда не обращал внимания, случайно отредактировал ее. Подбери их, и сборка теперь идёт нормально. Уф.

1
29.01.2009 14:36:58

Я обнаружил, что у меня была та же проблема, чтобы решить ее, я должен был установить

propel.runtime.conf.file=runtime-config.xml

в build.propertiesфайле.

После чего все заработало отлично.

3
14.07.2010 22:07:07