Как настроить совместимую кодовую среду между VxWorks 5.5 и 6.x?

У нас есть существующий проект VxWorks 5.5 и мы хотим перенести его на VxWorks 6.6.
VxWorks 6.x имеет множество новых возможностей (MMU, RTP и т. Д.), Которые мы не хотим использовать на данном этапе, поскольку это усложнит процесс переноса.

Как нам указать, что мы хотим, чтобы 5.5-совместимая среда?

10.12.2008 12:52:28
1 ОТВЕТ

При создании проекта VxWorks вы можете указать PROFILE_COMPATIBLE, который создает среду, совместимую с 5.5.

В верстаке это делается в диалоге создания нового проекта. Это 3-й или 4-й диалоговый экран под названием «Профиль конфигурации»

При создании проекта из командной строки с помощью vxprj просто добавьте параметр «-profile PROFILE_COMPATIBLE».

0
10.12.2008 12:57:22