Какую книгу GWT купить? Большинство, кажется, для версий 1.4

Я думал о том, чтобы получить GWT на практике от Роберта Купера или Google Web Toolkit Applications от Райана Дьюсбери

Однако они относятся к 08 мая и 07 декабря. Оба будут написаны для версии 1.4 - я просматривал примечания к выпуску, чтобы увидеть, что изменилось с тех пор:

Похоже, что ничего не изменилось с 1,6 до 1,7 http://code.google.com/webtoolkit/doc/1.7/ReleaseNotes_1_7.html.

Но материал, похоже, изменился с 1.5 до 1.6. «GWT 1.6 включает прямую поддержку вывода веб-архива (войны), более быструю компиляцию, новые виджеты, новую и улучшенную обработку событий и многое другое». http://code.google.com/webtoolkit/doc/1.6/ReleaseNotes_1_6.html

И, похоже, изменения с 1.4 до 1.5 http://code.google.com/docreader/#p=google-web-toolkit-doc-1-5&s=google-web-toolkit-doc-1-5&t=WhatsNewinGWT15

Я действительно хочу получить книгу, когда я новичок в чем-то, потому что я бы предпочел пролистывать страницы с извлеченными знаниями. Но я обеспокоен тем, что эти книги могут быть устаревшими. Любой совет, ребята?

Спасибо! Амбер

13.10.2009 06:42:36
2 ОТВЕТА

По моему мнению, любая существующая книга о GWT не стоит денег - все устарели. Потратьте несколько часов в книжном магазине или онлайн, чтобы получить всю необходимую информацию из этих книг.

1.6 - это принципиально другое, введя шину событий и обработчики. Да, от 1.6 до 1.7 - это только мелкие исправления.

Ждите новую книгу, которая покрывает 1.6 и позже - предпочтительно 2.0. Надеюсь, тот, который будет охватывать новые распространенные шаблоны - MVC / MVP, шаблон команд, джин / Guice и т. Д.

2
13.10.2009 14:40:56

Я не думаю, что есть смысл покупать какие-либо книги. Вскоре выйдет GWT 2.0, а книга, которую вы купите сегодня, завтра устареет.

0
2.11.2009 19:24:41
И если вы купите книги 2.0, скоро появятся книги 3.0, так что вы можете их подождать.
cdmckay 2.11.2009 19:26:43
Правда правда, тогда нет необходимости покупать какие-либо книги по программированию: D. Как у меня был ASP.NET 2.0, тогда я купил ASP.NET 3, а затем ASP.NET 3.5
Maksim 3.11.2009 17:28:58