Получение Subclipse в Aptana для работы с новейшим выпуском Subversion

Версия Subclipse (1.2.4), доступная в настоящее время через автоматический диспетчер плагинов Aptana, не работает с новейшей версией Subversion.

Однако на веб-сайте Subclipse я вижу, что у них есть 1.4.2 для Eclipse. Поэтому я добавил новый удаленный сайт обновлений в свой менеджер обновлений. Когда я попытался установить его, он сказал мне, что мне нужен Mylyn 3.0.0 . Поэтому после долгих поисков я нашел Mylyn 3.0.0 и добавил еще один новый удаленный сайт обновлений в свой менеджер обновлений. Затем, когда я попытался установить это, он сказал мне, что мне нужен org.eclipse.ui 3.3.0 или эквивалентный.

Глядя на детали конфигурации для Aptana, похоже, что он построен против затмения 3.2.2.

Кто-нибудь знает, есть ли способ обновить версию Eclipse Aptana, построенную на 3.3.0? Или есть ли какой-то другой способ заставить Subclipse работать с самой новой версией Subversion?

Я знаю, что это не обязательно вопрос «программирования», но я надеюсь, что это нормально, так как это очень важно для опыта программирования.

1.08.2008 13:56:33
4 ОТВЕТА
РЕШЕНИЕ

Subclipse не требует Mylyn, но сайт обновлений включает в себя плагин, который объединяет Mylyn и Subclipse. Это предназначено для людей, которые используют Mylyn. В вашем случае вы бы хотели просто отменить выбор Mylyn в диалоговом окне обновления.

Subclipse также требует Subversion 1.5 и соответствующей версии собственных библиотек JavaHL. Я написал начало FAQ, чтобы помочь людям понять JavaHL и как его получить. Смотрите: http://desktop-eclipse.open.collab.net/wiki/JavaHL

17
15.09.2008 13:26:34

У меня были проблемы с JavaHL в Eclipse Ganymede, когда он хорошо работал в Eclipse Europa. Я не уверен, чем отличается Aptana, но попробуйте либо обновить JavaHL, либо перейти на реализацию SVNKit на основе чистой Java в конфигурации Subclipse.

7
1.08.2008 14:41:01

если вы не собираетесь использовать mylyn, просто снимите эту зависимость. Я не очень знаком с Aptana, но в Eclipse вы можете расширить то, что установлено, и снять все, что вам не нужно.

4
28.08.2008 23:47:09

Я использовал URL обновления и я установил адаптер JavaHL, сам Subclipse проект и в SVNKit адаптер BETA.

После этого он работал нормально для меня, это для платформы Linux, надеюсь, это работает для вас.

3
26.08.2008 13:41:09