TortoiseSVN & Putty very slow

does anyone have a clue why the TortoiseSVN windows client (in Win32 XP and Vista) is so incredible slow when used with Putty and PAM? It seems it connects for each request since datatransfers (checkout) are not slow at all?

Any ideas how to change it?

Update: I had no problems with SSH before. But I have to use key based authentification.

18.08.2008 14:38:28
5 ОТВЕТОВ

Do you have a problem with standard SSH connections to the server as well? If it's generally slow to connect to your server via SSH, this could be a problem with reverse DNS lookups.

Andrew

3
18.08.2008 14:43:34

I don't use Putty for my ssh+svn connections. I use TortoisePlink, which is a wrapper around Putty, I think. It is provided by TortoiseSVN in the install directory under bin.

Basically go to the Settings dialog, by right clicking in a windows explorer window -> TortoiseSVN -> Settings

Click on the Network item in the tree. Setup your SSH client by providing the path to TortoisePlink:

C:\Program Files\TortoiseSVN\bin\TortoisePlink.exe -l username -pw password

I have not ran into any troubles running my svn server this way and connecting to it with TortoiseSVN over SSH. The speed is great and so is the security.

1
18.08.2008 14:51:40

What type of system are you connecting to? If you connect to OpenSUSE, for example, default DNS Reverse Lookup settings generally cause SSH connections to be very slow. If you can, put your client side IP address into the /etc/hosts table on the server. If Reverse DNS is your issue, this will resolve (remember to restart nscd daemon - "/etc/init.d/nscd restart" so that the change will take effect.)

SSH will be slower than native SVN protocol but not by an order or magnitude and not likely to a level that you will notice. But Reverse DNS timeouts could be several seconds per request.

0
2.10.2008 19:20:23

Ensure that there is a matching PuTTY session.

If your URL is

svn+ssh://xxx.yy/path/to/svn/trunk/foobar

then you need a session in PuTTY named

xxx.yy

which must be fully configured, especially in means of

  • username
  • private key file

I am using this together with Pageant.

0
28.03.2014 13:55:22

Try using Cygwin's version of ssh.exe.

I found this advice here, and it sped up my downloads by 3-5x

-1
20.03.2017 10:18:16